个股大盘指标公式

通达信分析大盘个股的公式 麻烦给我转成大智慧可以用的

你是L2还是经典?
L2:
K0:100*(CLOSE-HHV(HIGH,8))/(HHV(HIGH,8)-LLV(LOW,8))+100,COLORBROWN,LINETHICK1;
Z0:100*(CLOSE-HHV(HIGH,34))/(HHV(HIGH,34)-LLV(LOW,34))+100,COLORYELLOW,LINETHICK2;
M0:100*(CLOSE-HHV(HIGH,99))/(HHV(HIGH,99)-LLV(LOW,99))+100,COLORBLUE,LINETHICK1;
IF(K0>99,30.30,3),COLORBROWN;
IF(K0<1 ,70.70,97),COLORBROWN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
M:=SMA(K,3,1);
M1:=SMA(K,3,1);
G:=80;
涨幅:=100*(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
DRAWTEXT(CROSS(M,K)AND(M>=80)AND(涨幅<-0.9),M+3,'空仓');
DRAWTEXT(CROSS(K,M)AND(M<80),K-5,'持股');
DRAWTEXT(CROSS(M,K)AND(M<80),M+3,'空仓');
DRAWTEXT(CROSS(M,G),M,'强区'),COLORRED;
赚钱率:(ADVANCE)/(DECLINE+ADVANCE)*100,CROSSDOT,COLORBLUE;
P1:100,COLORBROWN;
P2:0,COLORBROWN;
N0:=赚钱率;N1:=REF(赚钱率,1);N2:=REF(赚钱率,2);
DRAWTEXT((MIN(N1,N0)>50)AND(N2<50.01)AND(M>K)AND(M<80),K-5,'短买');
DRAWTEXT((MIN(N1,N0)<50.01)AND(MIN(N1,N0)>47)AND(K<M)AND(M<80)AND(N2<47),K-5,'短买?');
DRAWTEXT((K<M)AND(N1<50.01)AND(N1>40)AND(N0>50)AND(M1<80),K-5,'短买');
KK:=100*(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,8)-LLV(LOW,8));
ZZ:=100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34));
MM:=100*(HHV(HIGH,99)-CLOSE)/(HHV(HIGH,99)-LLV(LOW,99));
DRAWTEXT((KK<3.11)AND(M<50),K,'卖?调');
DRAWTEXT((KK<3.11)AND((M>50)AND(M<80)),K,'卖?!调');
DRAWTEXT((KK<3.11)AND(M>80),60,'?');
DRAWTEXT(ZZ<1,70,'?');
DRAWTEXT(MM<1,80,'?');
DRAWTEXT((KK<3.11)AND(M1>80),K+2,'短高');
DRAWTEXT(KK>96.99,K,'次涨买');
DRAWTEXT(ZZ>89.9,30,'? ');
DRAWTEXT(MM>89.9,40,'? ');
--------------------------------------------------------------------------------------------
经典:
K0:100*(CLOSE-HHV(HIGH,8))/(HHV(HIGH,8)-LLV(LOW,8))+100,LINETHICK1;
Z0:100*(CLOSE-HHV(HIGH,34))/(HHV(HIGH,34)-LLV(LOW,34))+100,COLORYELLOW,LINETHICK2;
M0:100*(CLOSE-HHV(HIGH,99))/(HHV(HIGH,99)-LLV(LOW,99))+100,COLORBLUE,LINETHICK1;
IF(K0>99,30.30,3);
IF(K0<1 ,70.70,97);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
M:=SMA(K,3,1);
M1:=SMA(K,3,1);
G:=80;
AK:=100*(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
DRAWTEXT(CROSS(M,K)AND(M>=80)AND(ak<-0.9),M+3,'空仓');
DRAWTEXT(CROSS(K,M)AND(M<80),K-5,'持股');
DRAWTEXT(CROSS(M,K)AND(M<80),M+3,'空仓');
DRAWTEXT(CROSS(M,G),M,'强区'),COLORRED;
赚钱率:(ADVANCE)/(DECLINE+ADVANCE)*100,CROSSDOT,COLORBLUE;
P1:100;
P2:0;
N0:=赚钱率;N1:=REF(赚钱率,1);N2:=REF(赚钱率,2);
DRAWTEXT((MIN(N1,N0)>50)AND(N2<50.01)AND(M>K)AND(M<80),K-5,'短买');
DRAWTEXT((MIN(N1,N0)<50.01)AND(MIN(N1,N0)>47)AND(K<M)AND(M<80)AND(N2<47),K-5,'短买?');
DRAWTEXT((K<M)AND(N1<50.01)AND(N1>40)AND(N0>50)AND(M1<80),K-5,'短买');
KK:=100*(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,8)-LLV(LOW,8));
ZZ:=100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34));
MM:=100*(HHV(HIGH,99)-CLOSE)/(HHV(HIGH,99)-LLV(LOW,99));
DRAWTEXT((KK<3.11)AND(M<50),K,'卖?调');
DRAWTEXT((KK<3.11)AND((M>50)AND(M<80)),K,'卖?!调');
DRAWTEXT((KK<3.11)AND(M>80),60,'?');
DRAWTEXT(ZZ<1,70,'?');
DRAWTEXT(MM<1,80,'?');
DRAWTEXT((KK<3.11)AND(M1>80),K+2,'短高');
DRAWTEXT(KK>96.99,K,'次涨买');
DRAWTEXT(ZZ>89.9,30,'? ');
DRAWTEXT(MM>89.9,40,'? ');

请高手完善通达信软件附图里表现的大盘线与个股线相关的指标公式。一条线表现个股,一条线是大盘的走势

个股线:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORRED;
大盘线:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORYELLOW;
大盘线,对应个股所属的大盘,比如:沪,深,中小,创业等。

请高手将这个副图改写成为在个股副图中显示大盘指标的公式

不会写公式喔

我想在股票软件里面添加一个“相对强度”指标,就是个股和大盘的强度比较,求那个高手给个编个公式

个股:= (CLOSE-REF(CLOSE,24))/REF(CLOSE,24)*100;
大盘:= (INDEXC-REF(INDEXC,24))/REF(INDEXC,24)*100;
强弱值:EMA(个股-大盘,2);
0,DOTLINE,COLORRED;
由于软件函数的限制,只能在日线及以上周期状态上显示。

求高人写个通达信大盘和板块和个股强弱排列副图指标,那个板块强哪个就排在上面的那种副图指标

这样的副图指标是没法做出来的。如果你想对比强弱,那直接用系统自带的功能就好了,通达信热门板块分析的快捷键是 .400(4前面有个小数点哈)

请问如何把大盘K线放到副图里,方便个股对照着看??

{通达信大盘指数K线副图指标}

DRAWKLINE(INDEXH,INDEXO,INDEXL,INDEXC);

大盘:INDEXC,COLORWHITE,NODRAW;

±:INDEXC-REF(INDEXC,1),COLORLIGRAY,NODRAW;

沪深:"000300$CLOSE",NODRAW;

_±:"000300$CLOSE"-REF("000300$CLOSE",1),COLORLIGRAY,NODRAW;

大盘指数:INDEXC,NODRAW;

最高指数:INDEXH,NODRAW;

最低指数:INDEXL,NODRAW;

涨家数:INDEXADV,NODRAW,COLORLIMAGENTA ;

跌家数:INDEXDEC,NODRAW,COLORGREEN;

MA5:MA(INDEXC,5),COLORFFFFFF;

MA10:MA(INDEXC,10),COLORYELLOW;

MA20:MA(INDEXC,20),COLORFF00FF;

MA60:MA(INDEXC,60),COLORGREEN;